Elephant: appello "disperato"

    • Iuris74
      Iuris74
      Bronzo
      Presente da: 01-27-2011 Contributi: 4
      Chiedo cortesemente un aiuto per l'installazione di Elephant.

      Le FAQ di Elephant, infatti, segnalano questo forum come ultima spiaggia, qualora tutti i tentativi fossero risultati vani.

      Cercherò di essere il più preciso possibile, ma spero comprenderete e giustificherete mie eventuali ignoranze tecniche.

      Da quel poco che ho capito, il problema è riferibile al database PostgreSQL, applicazione tanto facile da installare quanto difficile da disinstallare completamente dal computer.

      Tutto nasce da una prima installazione (con la versione 0.90 di Elephant) che, apparentemente, era andata a buon fine, ma devo aver fatto qualche pasticcio con il database postgreSQL.

      Sta di fatto che decido di disintallare sia elephant che il database, ma ora, volendo installarlo nuovamente, c'è qualche problema.

      Evidentemente devo aver creato qualche conflitto tra Elephant e il database, perché, contrariamente a quanto viene spiegato nelle FAQ, l'installazione del database non parte automaticamente al termine dell'installazione di Elephant: ne deduco che io abbia ancora installato il database (con tanto di profilo-password e quant'altro), ma sta di fatto che non riesco a connettermi al profilo già memorizzato di postgreSQL (o almeno quello che appare in default), e dunque l'Elephant è praticamente inutilizzabile, né a crearne uno nuovo e/o cancellare quello già esistente, peraltro vuoto perché mai utilizzato.

      All'avvio di Elephant, infatti, mi chiede di creare un nuovo database, ma, probabilmente per il motivo sopra spiegato, trovo già scritto un username e una password, evidentemente sbagliati, poiché mi segnala il noto errore "failed to establish a connection to '127.0.0.1' (n.b. ho letto la FAQ di Elephant n. 9, al riguardo, ma non ho neppure la voce 'postgreSQL tra i servizi!!).

      Tra l'altro, nella schermata principale di Elephant-----Database management non ho alcun database sotto "know databases", e se provo a crearne uno nuovo ritorno al problema di prima.

      Questa è la mia situazione, piuttosto ingarbugliata (magari per gli "esperti" è semplicissima.....^__^), e sarei grato a colui/coloro che sapranno darmi indicazioni su come risolvere questo problema.

      Come sistema operativo ho il Windows 7, e ho anche scaricato l'ultimo setup di Elephant (versione 0.102), anche se la prima installazione l'ho fatta con la versione 0.90, come già detto in precedenza).

      Probabilmente il problema è quello di riuscire a cancellare tutte le precedenti installazioni (sia di Elephant che di PostgeSQL), ed infatti così ho fatto, in base alle mie conoscenze limitate, ancor più limitate dall'utilizzo di windows 7, per certi aspetti diverso da Vista.

      Grazie a tutti

      Un saluto

      Simone
  • 8 risposte
    • Stockky
      Stockky
      Bronzo
      Presente da: 10-07-2008 Contributi: 9.921
      Ciao Iuris,
      benvenuto nel nostro forum!

      Dovresti risolvere il problema leggendo questi due topic:

      Disinstallare PostgreSQL

      Installare Postgres-Elephant: How-To

      Passaci a trovare più spesso! ;)
      Bye
      Stockky
    • Iuris74
      Iuris74
      Bronzo
      Presente da: 01-27-2011 Contributi: 4
      Ciao Stockky e grazie per la risposta velocissima, considerando che è 17 agosto, è più che apprezzabile! :D

      Dunque...ho letto per bene i thread che mi hai indicato, ho scaricato l'installer di postgres, vado per installarlo ma....ecco un nuovo problema!!! X(

      Seguendo le indicazioni su come installare postgres, ovvero qui Installare Postgres-Elephant: How-To

      al terzo passaggio 'Inizialize database cluster', dopo aver compilato i campi, clicco su next e mi appare questo messaggio di errore:

      "The 'Secondary logon' service is not running. This service is required for the installer to inizialize the database. Pleas start this service and try again".

      Consigli e/o suggerimenti?? :)

      Grazie per la pazienza

      Un saluto

      Simone
    • Stockky
      Stockky
      Bronzo
      Presente da: 10-07-2008 Contributi: 9.921
      Purtroppo non sono esperto in materia, ma ricordo che con quella guida la mia installazione era filata liscia.
      Immagino che te abbia scaricato le ultime versioni di entrambi i software, le quali saranno sicuramente più aggiornate rispetto alla guida. Magari con gli aggiornamenti è cambiato qualcosa.

      Ti rimando a questo video in inglese, è breve e spiega chiaramente i passaggi. Inoltre è molto più recente rispetto al topic.
      http://it.pokerstrategy.com/video/12228/

      Se sai l'inglese guardalo, ma se non lo sai guardalo lo stesso :)
      è molto breve (6 minuti) ma soprattutto ti fa vedere in schermo tutti i passaggi.
      In breve quello che emerge è che nelle versioni più recenti di Elephant l'installazione di PostgreSQL è contemporanea se non lo rileva sul pc, per cui molti passaggi della guida sono superati in automatico (tra cui quello che ti da problemi) e tutta l'installazione risulta molto più semplice ed intuitiva.

      Guardalo poi prova a rifare tutto daccapo.

      Poi sempre dalla pagina dell'Elephant http://it.pokerstrategy.com/software/9/

      c'è un'altra guida per disinstallare posgreSQL (potebbe essere più riassuntiva)
      http://it.pokerstrategy.com/software/article/752/
    • Mau3a
      Mau3a
      Bronzo
      Presente da: 04-11-2010 Contributi: 41
      io l ho provato ieri e non riuscendo a configurarlo ?( l ho disinstallato sia elephant sia PostgreSQL poi ho provato a reistallarlo ed ho avuto i tuoi stessi problemi 8o avendo gia avuto esperienze del genere con altri programmi non basta solo disistallarlo ma devi anche trovare e cancellare manualmente tutte le cartelle di elephant e PostgreSQL che di solito sono nascoste in appdata\local, fatto questo reistalli elephant e all apertura ti dovrebbre chiedere di istallare PostgreSQL dovrebbe funzionare cosi :) io ho fatto cosi

      io invece se qualcuno sa ho un problema ho importato la cartella degli ultimi 50 sit&go di partypoker gli altri gli ho cancellati tutti ma il grafico mi viene fuori in discesa e mi da i valori in negativo ed in rosso , mentre dovrei essere in positivo anche se di poco come posso fare? grazie
    • Iuris74
      Iuris74
      Bronzo
      Presente da: 01-27-2011 Contributi: 4
      Finalmente sono riuscito ad installare tutta la faccenda.....grazie a tutti per il supporto e per i consigli.

      Ora non mi resta che capire come funziona!!! :D :D

      Anzi...se avete topic al riguardo da consigliarmi.... :]

      Un saluto e ancora grazie

      Simone

      L'originale di Mau3aio l ho provato ieri e non riuscendo a configurarlo ?( l ho disinstallato sia elephant sia PostgreSQL poi ho provato a reistallarlo ed ho avuto i tuoi stessi problemi 8o avendo gia avuto esperienze del genere con altri programmi non basta solo disistallarlo ma devi anche trovare e cancellare manualmente tutte le cartelle di elephant e PostgreSQL che di solito sono nascoste in appdata\local, fatto questo reistalli elephant e all apertura ti dovrebbre chiedere di istallare PostgreSQL dovrebbe funzionare cosi :) io ho fatto cosi

      io invece se qualcuno sa ho un problema ho importato la cartella degli ultimi 50 sit&go di partypoker gli altri gli ho cancellati tutti ma il grafico mi viene fuori in discesa e mi da i valori in negativo ed in rosso , mentre dovrei essere in positivo anche se di poco come posso fare? grazie
    • Stockky
      Stockky
      Bronzo
      Presente da: 10-07-2008 Contributi: 9.921
      Hai seguito i passaggi del video o hai fatto in un'altro modo?


      Cmq se è la prima volta che usi Elephant puoi guardare questo tutorial.
      La versione illustrata non è recente ma le funzioni sono le stesse.
      http://it.pokerstrategy.com/video/2399/
    • Stockky
      Stockky
      Bronzo
      Presente da: 10-07-2008 Contributi: 9.921
      L'originale di Mau3a
      io invece se qualcuno sa ho un problema ho importato la cartella degli ultimi 50 sit&go di partypoker gli altri gli ho cancellati tutti ma il grafico mi viene fuori in discesa e mi da i valori in negativo ed in rosso , mentre dovrei essere in positivo anche se di poco come posso fare? grazie
      Cioè in pratica il grafico tiene conto anche dei sit che hai cancellato?
      Prova ad usare i filtri, così che non tenga conto di quelli più vecchi
    • Iuris74
      Iuris74
      Bronzo
      Presente da: 01-27-2011 Contributi: 4
      L'originale di StockkyHai seguito i passaggi del video o hai fatto in un'altro modo?


      Cmq se è la prima volta che usi Elephant puoi guardare questo tutorial.
      La versione illustrata non è recente ma le funzioni sono le stesse.
      http://it.pokerstrategy.com/video/2399/
      ho fatto nel modo indicato da Mau3a.

      Ora però c'è il "problema" di come farlo funzionare.

      Il video da te indicato è molto esplicativo ed intuitivo, ma, essendo un'altra versione, non tutte le funzioni corrispondono, purtroppo.

      Ad esempio, al minuto 4.39 del video (così sono più chiaro), spiega come configurare le singole poker room, ma nella versione attualmente da me installata (la 0.102), la sezione (a destra) "Configure auto-import setting" non c'è!!

      In verità c'è l'auto import sotto il menù "Configuration", ma andando ad inserire il folder dove ho salvato le handhistory non riesce ad importare le mani!

      Ho provato anche l'importazione manuale ma niente da fare.

      Per caso c'è un minimo di mani richiesto (magari per ragioni statistiche...) affinché l'importazione funzioni??

      Ovviamente ho inserito la lingua inglese sia su elephant che su pokerstars.


      Grazie per la pazienza

      Un saluto

      Simone

      EDIT:

      ho risolto.....per pokerstars bisogna utilizzare un piccolo convertitore di mani..... :)

      Ora non ho più scuse..... :]