PROCEDURA a,- --> € ...ora HEM non funziona più!!!

    • aderenza
      aderenza
      Bronzo
      Presente da: 03-01-2011 Contributi: 289
      AIUTO!!!!!
      ?(
      ;( ;(

      Ho fatto la procedura per convertire i caratteri strani di HEM in euro, ora i caratteri sono euro.... ma non riesco più a vedere i nuovi sit in HEM !!!!!!

      Qualcuno può aiutarmi?

      Ho un backup del Database... dite che devo fare la restore? Vorrei tenerlo come ultimo salvataggio... voi che mi suggerite di fare?


      ecco le procedura che ho fatto e che mi ha dato exit 0

      CREATE FUNCTION replace_trash_w_euro() RETURNS trigger AS $replace_trash_w_euro$

      BEGIN
      NEW.handhistory := replace(NEW.handhistory,'€', '€');
      RETURN NEW;
      END

      $replace_trash_w_euro$ LANGUAGE plpgsql;

      CREATE TRIGGER eurosymbol BEFORE INSERT ON handhistories
      FOR EACH ROW EXECUTE PROCEDURE replace_trash_w_euro();
  • 2 risposte
    • aderenza
      aderenza
      Bronzo
      Presente da: 03-01-2011 Contributi: 289
      Ho provato a creare un nuovo database ed importare il backup ma niente :(

      Le mani le importa (vedo nell'HUD che aumentano le statistiche), ma non vedo nessuna entry in termini di Tornei SNG... Credo che non riesce più a leggere il carattere € ... :(

      A questo punto visto che anche con un nuovo Database non funziona temo che sia un errore di Postgres.

      Probabilmente mi conviene disinstallare tutto e poi reinstallare oppure qualcuno conosce la procedura per tornare indietro ed avere il carattere strano a,- che corrisponde a € e così far funzionare HEM?

      Ciao e grazie a tutti
    • aderenza
      aderenza
      Bronzo
      Presente da: 03-01-2011 Contributi: 289
      L'originale di aderenzaHo provato a creare un nuovo database ed importare il backup ma niente :(

      Le mani le importa (vedo nell'HUD che aumentano le statistiche), ma non vedo nessuna entry in termini di Tornei SNG... Credo che non riesce più a leggere il carattere € ... :(

      A questo punto visto che anche con un nuovo Database non funziona temo che sia un errore di Postgres.

      Probabilmente mi conviene disinstallare tutto e poi reinstallare oppure qualcuno conosce la procedura per tornare indietro ed avere il carattere strano a,- che corrisponde a € e così far funzionare HEM?

      Ciao e grazie a tutti
      Se può servire a qualcuno:

      Ho aggiornato HEM ed ora riesco a vedere le partite,... inconveniente: ho importato HUD di salsa ma non vedo nessun HUD :(

      Addirittura quando faccio partire l'autoimport non vedo nessuna finestra che compare.... a qualcuno è già successo? Sembra che il TableManager non funzioni.