psw postgres installazione

    • Rickywawis
      Rickywawis
      Bronzo
      Presente da: 09-13-2009 Contributi: 255
      ragazzi sto impazzendo...
      sto trasferendo per la prima volta dei dati da un computer all'altro e voglio importare i database che avevo sul notebook al pc fisso dove non avevo installato HEM.
      Avevo già installato Postgres ma all'accesso tramtite PGadmin mi dava qualche problema quindi ho deciso di disinstallarlo e poi di reinstallarlo...
      ora quando alla prima schermata di installazione postgres mi chiede la password da settare metto la mia solita e mi dice che la password non è corretta...ho provato pure a cambiarla ma mi da lo stesso errore..come cavolo faccio ora?
  • 22 risposte
    • arahell
      arahell
      Bronzo
      Presente da: 07-04-2009 Contributi: 5.826
      Ciao Rickywawis,
      prova a fare cosi': cerca con la funzione apposita di windows il file "Edit pg_hba.conf". Una volta trovato, cliccaci su con il tasto destro e seleziona "Apri con..", selezionando poi un editor di testo (Magari blocco note). Una volta aperto, clicca su modifica in alto e poi su "Sostituisci". Accanto a trova inserisci "md5" ed accanto a sostituisci con inserisci "trust" (Miraccomando, entrambe le voci senza apici). Fatto questo, entra nuovamente su PGAdmin e dovrebbe chiederti di impostare una nuova password. Fallo e, una volta sistemato tutto, ripeti tutta l'operazione che hai fatto con il blocco note, semplicemente invertendo la procedura del sostituisci (In pratica, inserisci "trust" accanto alla voce trova e "md5" accanto alla voce Sostituisci Con).

      Dimmi se riesci a risolvere cosi'.

      A presto,
      Arahell
    • Rickywawis
      Rickywawis
      Bronzo
      Presente da: 09-13-2009 Contributi: 255
      ciao arahell grazie...
      ma putroppo già i partenza non trovo il filche mi hai detto di cercare tu!! :(
    • orcoboia
      orcoboia
      Bronzo
      Presente da: 08-04-2010 Contributi: 897
      hai provato con postgrespass? l'utenza standard è postgres/postgrespass
      magari è quella semplicemente...
    • arahell
      arahell
      Bronzo
      Presente da: 07-04-2009 Contributi: 5.826
      Ciao rickywawis,
      L'originale di orcoboiahai provato con postgrespass? l'utenza standard è postgres/postgrespass
      magari è quella semplicemente...
      +1 ;)

      Prova la password che ci ha gentilmente ricordato orcoboia e facci sapere :)

      A presto,
      Arahell
    • Rickywawis
      Rickywawis
      Bronzo
      Presente da: 09-13-2009 Contributi: 255
      grazie orcoboia ho provato ma niente da fare...ne sto uscendo matto anche perchè nn posso usare hem così...
      arahell c'è un percorso dove posso trovare il file che dicevi prima?
    • Rickywawis
      Rickywawis
      Bronzo
      Presente da: 09-13-2009 Contributi: 255
      il problema è che mi sono accorto che postgres non è proprio più installato perciò dovrei riuscire a reinstallarlo ma mi da quel problema della pass!
    • arahell
      arahell
      Bronzo
      Presente da: 07-04-2009 Contributi: 5.826
      Ciao Rickywawis,
      prova a disinstallarlo correttamente come spiegato nella nostra FAQ di PostgreSQL e reinstallalo correttamente sempre seguendo la medesima guida.

      Fammi sapere gli sviluppi ;)

      A presto,
      Arahell
    • Rickywawis
      Rickywawis
      Bronzo
      Presente da: 09-13-2009 Contributi: 255
      Ciao arahell
      sono riuscito a installare postgres tramite holdem manager ma continuo a non andarne fuori...
      postgres 9.0 non riuscivo ad installarlo e mi dava questo problema della pass...ma quando sono nel pagadmin la 9.0 la vedo come la 8.4 che ho installato tramite hm...è normale?
      il problema ora è che i non mi fa più il ripristino del db che avevo salvato dal portatile...può essere che cambiando la versione di postgres non lo riconosca? ?(
      aiutooooooooooo
    • arahell
      arahell
      Bronzo
      Presente da: 07-04-2009 Contributi: 5.826
      Ciao Rickywawis,
      i db riconoscono solo ed esclusivamente la versione di Postgres con cui sono installati. Riesci a ripristinare la versione originale ?

      A presto,
      Arahell
    • Rickywawis
      Rickywawis
      Bronzo
      Presente da: 09-13-2009 Contributi: 255
      L'originale di arahellCiao Rickywawis,
      i db riconoscono solo ed esclusivamente la versione di Postgres con cui sono installati. Riesci a ripristinare la versione originale ?

      A presto,
      Arahell
      no mi da quel problema che ti dico della pass :(
    • arahell
      arahell
      Bronzo
      Presente da: 07-04-2009 Contributi: 5.826
      Ciao Rickywawis,
      ok, riproviamo con la procedura che ti avevo suggerito in precedenza, ho trovato il percorso del file di cui ti parlavo:

      1. Vai su C:\Programmi\PostgreSQL\8.x\data, sposta il file pg_hba.conf sul desktop, cliccaci su con il tasto destro ed aprilo con blocco note;
      2. Vai verso il fondo del documento e sostituisci tutte le voci "md5" con "trust" (senza apici). Salva e chiudi il file;
      3. Sposta nuovamente il file nella cartella da cui l'avevi preso;
      4. Riavvia il servizio PostgreSQL: Pannello di Controllo -> Strumenti di Amministrazione -> Servizi. Ti bastera cliccare con il tasto destro sulla voce "PostgreSQL" e cliccare su riavvia servizio.

      Adesso postgreSQL dovrebbe accettare qualsiasi password.

      Fammi sapere se risolvi :)

      A presto,
      Arahell
    • Rickywawis
      Rickywawis
      Bronzo
      Presente da: 09-13-2009 Contributi: 255
      Ciao arahell...grazie per l'aiuto...
      purtroppo però il mio problema è che riesco ad installare postgres 8.4 ma non il 9.0 qui il problema che ancora prima di installarlo qualsiasi pass metta non va bene...
      anche se una volta installato l'8.4 (fornito da hm) quando entro in pgadmin mi appare pure il 9.0 ?(

      oltretutto hm da errori nell'importazione delle mani quindi non mi appare nemmeno l'hud al tavolo!! ;(
    • arahell
      arahell
      Bronzo
      Presente da: 07-04-2009 Contributi: 5.826
      Ciao Rickywawis,
      purtroppo, l'unica cosa che mi viene in mente, è disinstallare e reinstallare nuovamente postgre, questa volta però con la versione con cui avevi installato il tuo database :( Ecco la procedura:

      Disinstallazione:
      D: Come faccio a disinstallare totalmente PostgreSQL?
      R: E’ abbastanza inutile disinstallare PostgreSQL, tranne nei casi in cui siano state eseguite due installazioni e quindi il sistema sia diventato instabile e/o non accessibile. Basta andare in pannello di controllo -> programmi e funzionalità (per Vista) o installazione applicazioni (per XP), selezionare PostgreSQL e disinstallarlo. Una volta disinstallato, dovrete anche eliminare l’utente postgres associato (cosa che non viene fatta in automatico dall’uninstaller). Per farlo, andate nel menù Start -> Programmi -> Accessori -> Prompt dei comandi, e una volta aperta la finestra del prompt, digitate: net user postgres /del
      A questo punto il vostro PC è stato ripulito da qualsiasi installazione di PostgreSQL, e potete effettuare una nuova installazione da 0 senza problemi.
      (Presta particolare attenzione alla parte in grassetto)

      Installazione:
      D: Come faccio ad installare correttamente PostgreSQL ?
      R:
      A questo URL scegliete, dall'elenco, la versione adatta al vostro sistema operativo (Per i meno esperti, generalmente si tratta di Winx86-32). Una volta scaricato il file zip, scompattatelo in una cartella a vostro piacimento. Lanciate il file postgresql-x.x.msi, le x.x indicano la versione. Cliccate avanti, e vi comparirà come seconda questa finestra. Selezionate le componenti da installare così come le vedete nella finestra, e come Current Location inserite la directory dove volete installare Postgres (se non sapete cosa significa o dove farlo, non toccate quel campo!). Di default, la directory sarà C:\Programmi\PostgreSQL\x.x\ se usate XP oppure C:\Program files (x86)\PostgreSQL\x.x\ se usate Vista. Proseguite fino alla comparsa di questa finestra. Lasciate Service Name e Account Name di default (come li leggete nell'immagine), nel campo Account Domain comparirà il nome del vostro PC (lasciate anche questo così com'è senza toccarlo). L'unica cosa che dovrete scegliere è la password da associare all'utente "postgres", sceglietene una a vostro piacimento e inseritela negli ultimi due campi e proseguite. SE Postgres vi avvisa che la password è "debole", NON ditegli di modificarla con una password generata da lui stesso. Dopodiché, vi comparirà questa finestra. Gli unici campi che dovrete modificare sono gli ultimi tre:
      - Superuser name: inserite un nome a vostro piacimento.
      - Password: la password che verrà legata all'uso del Superuser.
      - Password (again): ripete la password.
      A questo punto avete terminato l'installazione, l'ultima finestra che vi comparirà sarà questa. Deselezionate la casella accanto a Launch Stack Builder at exit e cliccate su Finish.
      Mi spiace ma non vedo alternative :\

      A presto,
      Arahell
    • pippetto86
      pippetto86
      Bronzo
      Presente da: 12-28-2010 Contributi: 1
      Ciao, avevo un problema simile al tuo e casualmente mi sono reso conto che sia account che pass erano individuati dalla medesima parola ossia: postgres
      e non come usualmente accade postgres/postgrespass

      spero che questo sia di aiuto

      ALESSANDRO
    • Rickywawis
      Rickywawis
      Bronzo
      Presente da: 09-13-2009 Contributi: 255
      sono ancora alle prese con il problema ma mi sento di essere vicino alla risoluzione :-)
      qualcuno sa se fa differenza ad esempio la versione 9.0.0 di postgres rispetto alla 9.0.2?
      xk non riesco a trovare la prima che è esattamente quella che ho sul laptop! :-(
    • Rickywawis
      Rickywawis
      Bronzo
      Presente da: 09-13-2009 Contributi: 255
      no eh? :(
    • arahell
      arahell
      Bronzo
      Presente da: 07-04-2009 Contributi: 5.826
      Ciao Rickywawis,
      dovrebbe essere questo qui, fammi sapere se và ;)

      A presto,
      Arahell
    • Rickywawis
      Rickywawis
      Bronzo
      Presente da: 09-13-2009 Contributi: 255
      ciao arahell ho installato la versione che mi hai dato dopo una formattazione che ci voleva per questo pc...
      ora al momento del ripristino del backup del laptop postgres mi da questo:

      Il processo ha ritornato il codice di uscita 1.C:/Programmi/PostgreSQL/9.0/bin\pg_restore.exe --host localhost --port 5432 --username postgres --dbname \"Cash\" --verbose "C:\Documents and Settings\Riccardo\Desktop\Cash.backup"pg_restore: troppi argomenti nella linea di comando (il primo è "--verbose")Consultare "pg_restore --help" per maggiori informazioni.Il processo ha ritornato il codice di uscita 1.

      ?( ?( ?(
    • Rickywawis
      Rickywawis
      Bronzo
      Presente da: 09-13-2009 Contributi: 255
      nessuno sa qualcosa? :(
    • 1
    • 2