errore connessione hold em manager

    • thedandy
      thedandy
      Bronzo
      Presente da: 05-19-2009 Contributi: 37
      ciao a tutti !!! volevo kiedere un grande favore visto ke ormai nn riesco piu ad accedere ad hold em manager!!! ogni volta ke lo apro mi appare la scritta

      " the following error occurred when trying to open the database: failed to establish a connection to 127 0 0 1"

      penso si un problema di postgres ma essendo totalmente ignorante in materia imploro un aiuto a chiunque fosse competente in materia!!!

      grazie in anticipo
  • 17 risposte
    • arahell
      arahell
      Bronzo
      Presente da: 07-04-2009 Contributi: 5.826
      Ciao thedandy,
      è un problema noto, infatti puoi trovare la procedura per risolverlo nella Faq della Sezione. Consultala in futuro per vedere se le problematiche che incontri non sono già state affrontate ;)

      In ogni caso, per comodità, ti riporto la procedura per il tuo caso particolare:
      D: L’applicativo , quando lo lancio, mi dice “Failed to estabilish connection to 127.0.0.1” e non parte. Come posso risolvere?
      A: Questo succede perché il servizio PostgreSQL non è attivo. Per attivarlo, aprite il Pannello di Controllo -> Strumenti di Amministrazione -> Servizi, nella finestra appena aperta andate alla voce PostgreSQL Database Server x.x, doppio click sulla voce, e selezionate nel menu a tendina al centro della finestra “Automatico”. Con questa opzione, il servizio PostgreSQL partirà automaticamente ad ogni avvio del PC.

      Dimmi se così hai risolto ;)
    • thedandy
      thedandy
      Bronzo
      Presente da: 05-19-2009 Contributi: 37
      allora innanzitutto grazie per la risposta .... ho provato a seguire l iter ma era gia impostato su automatico la cosa ke ho notato pero è ke quando arrivo alla pagina per impostare sull avvio automatico sotto c è una scritta ke dice stato del servizio assente ho provato a farlo partire ma mi da errore
      1053(il servizio non ha risposto alla richiesta di avvio o contrllo nel tempo previsto)
    • arahell
      arahell
      Bronzo
      Presente da: 07-04-2009 Contributi: 5.826
      Ok, procedi con le seguenti operazioni e poi riprova farlo ripartire :) :
      1) scarica ed installa l'ultima versione diHM da qui;

      2) vai in Pannello di Controllo -> Account Utente, e deseleziona in fondo la voce “Attiva o disattiva Controllo account utente”, riavvia il PC e non riceverai più la richiesta ad ogni lancio dell’applicativo. Per quanto riguarda le credenziali come amministratore, sul vostro PC con un account indicato come Administrator (lo user di default è sempre un Administrator, in caso contrario, contattal’amministratore di sistema per farvi risolvere questo problema se siete in una rete gestita da terzi).

      3)Se hai un firewall, aggiungi holdem manager, nella lista delle eccezioni in modo da eseguiamo correttamente;

      Inizia provando così.. Fammi sapere ! :)
    • ElSamareno
      ElSamareno
      Bronzo
      Presente da: 01-03-2011 Contributi: 125
      L'originale di arahellOk, procedi con le seguenti operazioni e poi riprova farlo ripartire :) :
      1) scarica ed installa l'ultima versione diHM da qui;

      2) vai in Pannello di Controllo -> Account Utente, e deseleziona in fondo la voce “Attiva o disattiva Controllo account utente”, riavvia il PC e non riceverai più la richiesta ad ogni lancio dell’applicativo. Per quanto riguarda le credenziali come amministratore, sul vostro PC con un account indicato come Administrator (lo user di default è sempre un Administrator, in caso contrario, contattal’amministratore di sistema per farvi risolvere questo problema se siete in una rete gestita da terzi).

      3)Se hai un firewall, aggiungi holdem manager, nella lista delle eccezioni in modo da eseguiamo correttamente;

      Inizia provando così.. Fammi sapere ! :)
      purtroppo ho lo stesso problema
      premetto che ne mastico abbastanza di informatica e sono un figlio di dos (hehe) ma sono due giorni che installo e disinstallo holdem manager e postgresql. in internet nei vari forum non sono riuscito a trovare una risposta all'errore 1053 del database "il servizio non ha risposto alla richiesta di avvio o contrllo nel tempo previsto"
      nei servizi di sistema è presente il programma ma se faccio una prova con il comando dos "sc query" non me lo trova
      quindi sono abbastanza disperato e spero che qualcuno nel forum mi possa aiutare.
      please
    • arahell
      arahell
      Bronzo
      Presente da: 07-04-2009 Contributi: 5.826
      Ciao ElSamareno,

      hai detto che nel pannello di controllo il servizio lo trovi: ti permette di attivarlo ?

      A presto,
      Arahell
    • ElSamareno
      ElSamareno
      Bronzo
      Presente da: 01-03-2011 Contributi: 125
      intanto grazie dell'aiuto
      nei servizi di windows lo trova e provando ad avviarlo dopo poco più di un minuto mi dice che non è riuscito a connettersi e mi da come errore il 1053.
      Come sistema operativo ho Windows XP, antivirus e firewall sono Avast (quello di windows è disattivato). Automaticamente quando accendo il pc non mi chiede nesuna password e entro come administrator.
      Inizialmente avevo installlato la versione postgresql 9.1 che ho disinstallato con ccleaner e tramite i comandi dos ho eliminato anche la password.
      Allora ho provato ha installare la versione 8.3 ma presenta lo stesso errore.
      Mi viene da pensare che sia il pc molto vecchio (un pentium III) con poca ram.
      Ho provato a farlo partire disattivando anche avast ma niente.
      Spero tu possa aiutarmi o altrimenti mi cerco un viaggio per visitare il santuario di fatima che forse aveva anche un quarto segreto non ancora riveralto.
      Ciao e grazie
    • arahell
      arahell
      Bronzo
      Presente da: 07-04-2009 Contributi: 5.826
      Ciao ElSamareno,
      prova così:

      intanto, aggiungi ad entrambi i firewall (Windows e Avast) l'eccezzione per postgre e HM, anche se sono disattivati. Dopodichè, prova ad andare nei servizi e clicca con il tasto destro sul servizio "Accesso Secondario" -> Proprietà e nella tendina accanto alla scritta avvia seleziona automatico. Applica, torna indietro e fai la stessa cosa per il servizio di postgre. Infine, riavvia e vedi comè la situazione ;)

      Fammi sapere,
      A Presto !
      Arahell
    • ElSamareno
      ElSamareno
      Bronzo
      Presente da: 01-03-2011 Contributi: 125
      allora ho attivato anche il "secondary logon" e sia in avast che in windows firewall ho inserito il programma come eccezzione.
      Dopo ho riavviato il pc ma postgresql non parte e ho provato a farlo partire manualmente ma mi compare questo messaggio "Il servizio PostegreSQL Server 8.3 su Computer locale si è avviato, quindi si è interrotto. Alcuni servizi si interrompono automaticamente se non vi sono operazioni da eseguire, ad esempio il servizio Avvisi e registri di prestazioni."
      in rete ho trovato questo:
      # Ci posizioniamo nella cartella bin della cartella di installazione di Postgreasql (nel mio caso è c:\Programmi\PostgreSQL\8.3\bin
      # cancelliamo manualmente il servizio creato dall'installer : sc delete postgreasql-8.3
      # ricreiamo il servizio : pg_ctl register -N postgresql-8.3 -D c:\programmi\ PostgreSQL\8.3\data
      aspetto però cortesemente tue notizie prima di fare altre cose
      grazie arahell
    • ElSamareno
      ElSamareno
      Bronzo
      Presente da: 01-03-2011 Contributi: 125
      forse il problema è questo

      nei servizi il programma che avvia postgresql è
      C:/Programmi/PostgreSQL/8.3/bin/pg_ctl.exe runservice -N "postgresql-8.3" -D "C:/Programmi/PostgreSQL/8.3/data" -w

      come vedi le / sono al contrario perchè dovrebbero essere \ se non sbaglio
    • ElSamareno
      ElSamareno
      Bronzo
      Presente da: 01-03-2011 Contributi: 125
      seguo con le modifche che ho provato
      da dos nella carttella "c:\programmi\postgresql\8.3\bin" eseguo "pg_ctl unregister -N postgresql-8.3" ma non me lo esegue e mi dice
      "pg_ctl: illegal option -- n"
      allora ho provato a lanciarlo da dos eseguendo
      pg_ctl.exe runservice -N "postgresql-8.3" -D "C:\Programmi\PostgreSQL\8.3\data" -w
      ma mi dice
      pg_ctl: could not start service "postresql-8.3": error code 1063

      adesso esco a cercare un biglietto per il santuario perchè sono tilttao

      ciao
    • arahell
      arahell
      Bronzo
      Presente da: 07-04-2009 Contributi: 5.826
      Ciao ElSamareno,

      mi spiace per questi disguidi :\ ora faccio qualche ricerca e ti faccio sapere !

      A presto,
      Arahell
    • ElSamareno
      ElSamareno
      Bronzo
      Presente da: 01-03-2011 Contributi: 125
      sono tornato dal santuario di fatima ma non mi ha svelato il quarto segreto
      qualcuno ne è al corrente???
      purtroppo tutti i miei tentativi di far partire il database non sono andati a buon fine
      se avete problemi su postgresql (a parte il mio) kiedemi pure perchè mi sono fatto una cultura in materia
    • valassinehn
      valassinehn
      Bronzo
      Presente da: 05-19-2008 Contributi: 935
      ho avuto un problema similare con la 9.0
      quando avevo perso quasi tutte le speranze per i 15gb di database ho trovato in rete sto camando che va adattato alle tue directory.
      D:\Program Files\PostgreSQL\8.4\bin>pg_resetxlog -f "D:\Program Files\PostgreSQL\8.4\data"

      va lanciato da dos (cmd) nel caso ti dia problemi di blocco cancella come ho fatto io il file postmaster. pid da data e prova.
      Spero possa aiutare.....
    • valassinehn
      valassinehn
      Bronzo
      Presente da: 05-19-2008 Contributi: 935
      ho avuto lo stesso problema con la 9.0 ad un certo punto non mi si voleva + avviare il servizio..
      le ho provate tutte :cambiare l'utente, disistallare e reinstallare postgres 9.0 (che tanto la cartella data l'ha mantiene) ma niente sempre errore...
      Quando avevo perso le speranze per il mio database da ben 15gb ho trovato in rete sto comando

      D:\Program Files\PostgreSQL\8.4\bin>pg_resetxlog -f "D:\Program Files\PostgreSQL\8.4\data"

      l'ho adattato alle mie path e lanciato da dos. al primo di ha dato un errore sui blocci dei file allora ho cancellato il file postmaster.pid dalla data e per magia il servizio sono riuscito a farlo partire...
      ora hem ha ripreso a funzicare:)
    • ElSamareno
      ElSamareno
      Bronzo
      Presente da: 01-03-2011 Contributi: 125
      il comando dos è andato a buon fine ma postgresql non si avvia.
      ormai ci ho rinunciato fino all'acquito di un nuovo pc (quello che ho è obsoleto)
      grazie comunque dell'aiuto
    • ErCesko
      ErCesko
      Bronzo
      Presente da: 11-17-2009 Contributi: 8
      Ciao, ho problemi con HM...lo apro e mi appare questo:




      Clicco "OK" e mi porta al Database Control, dove cliccando "Connect" mi appare questo messaggio:



      Cliccando "Yes" mi vengono in successione questi 2 messaggi:


      Vi ringrazio per il vosto eventuale aiuto, purtroppo non son molto pratico e non saprei proprio dove metter le mani:rage:
    • ErCesko
      ErCesko
      Bronzo
      Presente da: 11-17-2009 Contributi: 8
      Ciao! Io ho risolto!!

      Provate a cancellare il file: "postmaster.pid"

      C:\Program Files\postgresql\8.x\data\postmaster.pid file


      Cancellate il file, riavviate il pc e aprite HM...a me è andato, spero vada anche a voi