Postgre

    • TheArchistar
      TheArchistar
      Bronzo
      Presente da: 04-15-2009 Contributi: 656
      Non so se avete avuto a che farne anche voi durante l'installazione di holdemmanago pt3, accade generalmente se si utilizza windows vista presumo.

      Ad ogni modo scarico holdemmanager e mi dice che devo prima installare postgre, mi reco quindi sul sito che consiglia lui stesso per la risoluzione del problema: http://www.holdemmanager.net/faq/afmviewfaq.aspx?topicid=35&faqid=176 seguo tutte le iscrizioni senza nessun problema..dopo il passaggio 10 parte l'effettiva installazione ma ad un certo punto mi vien fuori: User "postgres" could be not created: The user account already existes!

      A qualcuno è già successo?! Qualcuno può aiutarmi? E' due giorni che ci sbatto la testa e non so come uscirne :( :f_confused: :f_confused:
  • 24 risposte
    • Memphis87
      Memphis87
      Bronzo
      Presente da: 12-01-2008 Contributi: 1.129
      Per caso hai già installato qualche volta pt3? Cmq devi controllare perchè pare che tu lo abbia già installato. ;)
    • TheArchistar
      TheArchistar
      Bronzo
      Presente da: 04-15-2009 Contributi: 656
      sìsì, avevo lo installato per pt3, ad ogni modo me l'ha fatto cancellare..lo disinstallai, cancellai ogni traccia di postgree su pc e rifaccio tutto il procedimento ma solito problema, non sono dove sbattere la testa :f_cry: :f_cry:
    • valentik72
      valentik72
      Bronzo
      Presente da: 10-02-2006 Contributi: 6.180
      prova a seguire questo topic

      http://www.holdemmanager.net/forum/showthread.php?t=5363&page=4
    • TheArchistar
      TheArchistar
      Bronzo
      Presente da: 04-15-2009 Contributi: 656
      L'originale di valentik72prova a seguire questo topic

      http://www.holdemmanager.net/forum/showthread.php?t=5363&page=4
      Ti ringrazio molto per il link! Era perfetto! Infatti ora quell'errore non me lo da più! In compenso me ne da un altro subito prima di finire l'installazione :D :D :D


      "failed to connect to the database. Procedurale languages files are installed, but are not activated in any databases"

      Sta diventando un'odissea installare hold em manager ahhaha
    • Galandil
      Galandil
      Bronzo
      Presente da: 02-19-2008 Contributi: 4.997
      Allora, disisntalla a dovere tutte le installazioni di postgres che hai sul tuo pc.

      Una volta fatto ciò, vai nel Pannello di Controllo -> Strumenti di Amministrazione e lancia GEstione computer.

      Clicca sulla voce Utilità di Sistema->Utenti e Gruppi locali->Utenti e guarda l'elenco a destra.

      Dovresti trovare nell'elenco: Administrator, Guest, i tui utenti di XP/Vista e postgres. Elimina l'utente postgres più tutti quelli a te sconosciuti.

      Fatto ciò, reinstalla l'ultima versione di postgres.
    • TheArchistar
      TheArchistar
      Bronzo
      Presente da: 04-15-2009 Contributi: 656
      mmmm ho disinstallato tutto..cancellato tutta la roba necessaria dalla cartella User..andato nel dos e fatto il lavoro net user blabla /del

      Vado per reinstallare postgres fiducioso,arriva quasi alla fine e mi ridà sto problema:

      "Failed to connect to database. Procedural languages files are installed,but are not activated in any database."


      e cliccando ok mi vien fuori:

      "could not connect to server: connection refused (0x0000274D/10061) Is the server running on host "127.0.01" and accepting TCP/IP connections on port 5432"

      Per il quale ho trovato anche questa pagina di pokerstrategy su google con qualcuno che aveva avuto il mio stesso problema:

      http://fr.pokerstrategy.com/forum/thread.php?threadid=35743

      ed inoltre ho trovato anche questo che potrebbe essere utile (è un link esterno, spero non sia un problema):

      http://www.nntp.it/comp-software-database/1268288-qgis-e-postgresql-non-si-connette.html


      Una volta ricliccato ok mi vien fuori:

      "Failed to connect to the "template1" database. Contrib files are installed, but are not activated in any databases"


      Per il quale ho trovato questo link al sito di hm:

      http://www.holdemmanager.net/forum/showthread.php?t=9030 dove c'è un tizio che ha la mia stessa sequenza d'errori (penultimo post).




      Sto postgres mi sta mandando al manicomio, è da giorni e giorni che ormai ci sto dietro :f_cry: :f_cry: :f_cry: :f_cry:
    • vale4466
      vale4466
      Bronzo
      Presente da: 11-16-2008 Contributi: 174
      ho appena risolto il tuo stesso problema cancellando dal prompt i vari user
      net user xxxx/del disistallato postgres e cancellato manualmente la cartella
      postgre dentro c>>>programmi che nn si toglie da sola, rimosso gli utenti creati
      da postgre dentro c>>>>utenti e soprattutto capito che login name è il
      superuser impostato durante l'istallazione.
      spero tu possa risolvere ciao.
    • TheArchistar
      TheArchistar
      Bronzo
      Presente da: 04-15-2009 Contributi: 656
      allora..ci sono novità..

      in pratica ieri dopo tutto quello che ho scritto preso dallo sconforto ho spento tutto e me ne sono andato a vedere un film lol


      Stamattina mi dico vabeh..proviamo ad arrivare pt3 e vediamo che succede..che è partito e va tutto mi pare :f_confused:

      quindi boh..meglio! :D :D :D

      Però mi chiedo allora tutti quegli errori come mai..o se comunque un problema esiste ma non me ne sono accorto visto che sono seminuovo del software :f_mad:

      P.s: Le faccine dei fish sono fantastiche :D :D :D
    • Tie86
      Tie86
      Bronzo
      Presente da: 06-11-2009 Contributi: 3.156
      io ho un altro problema!!!

      sono riuscito a mettere a posto postgre con PT3 che funziona a meraviglia con titan!!!

      solo che volevo provare a vedere com'era Holdem Manager e non riesco a farlo partire!

      mi dice di creare un database per HM e quando vado per crearlo mi esce questo problema:

      The following error occurred when trying to initialize the Holdem Manager database: ERROR: 22023: new encoding (SQL_ASCII) is incompatible with the encoding of the template database (UTF8)

      cosa può essere? posso avere un database per pt3 e uno per HM?
    • Tie86
      Tie86
      Bronzo
      Presente da: 06-11-2009 Contributi: 3.156
      nessuno sa niente? please!!!
    • Galandil
      Galandil
      Bronzo
      Presente da: 02-19-2008 Contributi: 4.997
      Mah, è stranissimo che ti dia un errore simile (entrambe le codifiche dovrebbero essere disponibile in postgres). Sei sicuro di aver installato l'ultima versione di postgres?
    • Tie86
      Tie86
      Bronzo
      Presente da: 06-11-2009 Contributi: 3.156
      si ho dovuto reinstallare proprio oggi postgre ed è l'ultima versione!!!

      adesso non mi va neanche pt3!

      allora per holdem manager rimane lo stesso problema!

      per pt3 è successo questo: stavo facendo una sessione ed è andata via la corrente! dopo un pò ho riacceso tutto normalmente! ho fatto partire pt3 e mi esce questo errore:

      Pokertracker was unable to connect to any Postgre SQL databases.
      Please make sure you have PostgreSQL running.
      Please see this forum post for more information.

      ho controllato quando ho reinstallato postgre ed è attivo anche se esce così! please!


      edit: pt3 l'ho sistemato! ho dovuto reinstallarlo! holdem manager rimane il problema!
    • Galandil
      Galandil
      Bronzo
      Presente da: 02-19-2008 Contributi: 4.997
      Non avevi bisogno di reinstallare postgresql (e spero che tu abbia disinstallato la vecchia installazione con tanto di cancellazione dell'utente, altrimenti nel tuo pc c'è un casino indescrivibile...), bastava andare a riattivare il servizio Postgres che dopo il blackout evidentemente non era partito in automatico al riavvio del pc.

      A riguardo di HM, la cosa è davvero assurda, visto che SIA PT3 SIA HM utilizzano la codifica SQL_ASCII per i loro db.

      Prova a lanciare pgAdmin III (lo trovi nel menu programmi in postgres), poi clicca tasto dx su PostgreSQL Database Server -> Connetti, clicca sul +, clicca di nuovo sul + alla voce Database, e clicca una volta il sx sui vari database presenti, e controlla la codifica (e vedi anche se è presente un db di HM e che codifica indica).
    • Tie86
      Tie86
      Bronzo
      Presente da: 06-11-2009 Contributi: 3.156
      sisi ho fatto tutta la disinstallazione completa! :D

      sono andato a cercare come mi hai detto!

      ho 2 database presenti!

      uno giusto! PT3 DB che ha come codifica SQL_ASCII

      e un altro chiamato "postgres" con codifica UTF8!


      cos'è quest ultimo?
    • Galandil
      Galandil
      Bronzo
      Presente da: 02-19-2008 Contributi: 4.997
      Quello è il db di gestione di PostgreSQL stesso. La cosa strana è che tu ce l'hai in UTF8, mentre il mio ha codifica WIN1252 (che è una sottocodifica del gruppo UTF8).

      Per curiosità, che versione hai di PostgreSQL? Non vorrei fosse una versione molto vecchia.

      Nel frattempo, prova a fare così.

      Da pgAdmin III, connettiti al database, clicca su postgres, e poi vai al menu Strumenti e scegli Strumento Query.

      Ti si apre una nuova finestra, controlla che nel menu a tendina in alto a dx ci sia scritto "postgres su <tuo superusername>@localhost:5432".

      Nella prima finestra (quella in alto a sx) scrivi questo:

      RESET client_encoding;

      e poi clicca sul tasto play verde in alto a sx del menu a tendina (il rollover col mouse ti deve dire "Esegui l'interrogazione".

      Una volta fatto, sostituisci nella finestra la parola RESET con la parola SHOW, e rifai l'interrogazione, in basso ti dovrebbe comparire una riga con indicato WIN1252.

      A questo punto prova a creare un db con HM e vedi se funziona.
    • Tie86
      Tie86
      Bronzo
      Presente da: 06-11-2009 Contributi: 3.156
      ho l'ultima versione! l'avevo appena reinstallato!

      ho fatto tutto solo che quando scrivo RESET client_encoding; e faccio partire mi esce scritto:

      ERROR: CREATE DATABASE cannot be executed from a function or multi-command string

      ********** Errore **********

      ERROR: CREATE DATABASE cannot be executed from a function or multi-command string
      Stato SQL: 25001

      :f_cry:
    • Galandil
      Galandil
      Bronzo
      Presente da: 02-19-2008 Contributi: 4.997
      Non capisco cosa c'entri il create database con il reset della variabile.

      Fai na cosa: in basso c'è il "Riquadro di output", dopo aver lanciato il reset, vai al tab Cronologia e copia/incolla qui il testo integrale dell'output.

      Cmq dimmi esattamente il numero di versione di PostgreSQL, tnx.
    • Tie86
      Tie86
      Bronzo
      Presente da: 06-11-2009 Contributi: 3.156
      il num di versione che dici è quello che mette anche come nome nella cartella dove lo installi giusto? è l' 8.4!

      e in cronologia esce così:

      -- Interrogazione in esecuzione:
      -- Database: postgres

      -- DROP DATABASE postgres;

      CREATE DATABASE postgres
      WITH OWNER = postgres
      ENCODING = 'UTF8'
      LC_COLLATE = 'Italian_Italy.1252'
      LC_CTYPE = 'Italian_Italy.1252'
      CONNECTION LIMIT = -1;

      RESET client_encoding;

      ERROR: CREATE DATABASE cannot be executed from a function or multi-command string

      ********** Errore **********

      ERROR: CREATE DATABASE cannot be executed from a function or multi-command string
      Stato SQL: 25001
    • Galandil
      Galandil
      Bronzo
      Presente da: 02-19-2008 Contributi: 4.997
      Interessante, io ho la 8.3.5. Puoi provare a scaricare questa versione (o una qualsiasi 8.3.x), non vorrei che ci fosse qualche problema con postgres versione 8.4.x. Fammi sapere, stai avendo un problema davvero incredibile, mai capitato. :D
    • 1
    • 2