Elephant rifiuta il database

    • micaunaltropaolo
      micaunaltropaolo
      Bronzo
      Presente da: 03-26-2008 Contributi: 255
      ciao a tutti, aspettavo il momento buono per passarde a PT e a quanto sembra è arrivato :tongue:

      Da un giorno all'altro, senza che avessi installato nulla di nuovo sul computer, una volta aperto elephant mi salta fuori una finestrella che mi saluta dicendo qualcusa di molto simile a : "Il tuo database è obsoleto (oppure non compatibile con gli aggiornamenti, una cosa così mi pare di ricordare) " si può solo cliccare su ok vaboh.. poi la finestra " The first step is to create a new database. ecc ecc ecc "
      Vabeh insomma tagliando corto adesso è come se non avessi il db...

      Si può recuperare? mi scoccerebbe perderlo...
  • 10 risposte
    • micaunaltropaolo
      micaunaltropaolo
      Bronzo
      Presente da: 03-26-2008 Contributi: 255
      OS: Microsoft Windows NT 6.0.6001 Service Pack 1
      .NET Runtime: 2.0.50727.1434
      RAM: 2GB
      Processors: 2
      CPU: x64 Family 6 Model 15 Stepping 13: 9/64/1, 1667

      Software version: 0.67

      (10) Log: 17:02:13.09 -- Logfile set: C:\Users\Paolo\AppData\Local\PokerStrategy\Elephant\log.txt
      (10) Log: 17:02:13.10 -- Logfile cleared: C:\Users\Paolo\AppData\Local\PokerStrategy\Elephant\log.txt
      (10) Log: 17:31:11.43 -- , line 0: System.NullReferenceException: Riferimento a un oggetto non impostato su un'istanza di oggetto.
      in PokerStrategyElephant.DatabasesForm.Init()
      (10) , line 0: System.NullReferenceException: Riferimento a un oggetto non impostato su un'istanza di oggetto.
      in PokerStrategyElephant.DatabasesForm.Init()
    • Galandil
      Galandil
      Bronzo
      Presente da: 02-19-2008 Contributi: 4.997
      Dovresti controllare nell'elenco dei db, sarà sicuramente ancora presente, e dovrai "aggiornarlo" usando il Repair Database per renderlo funzionale.
    • micaunaltropaolo
      micaunaltropaolo
      Bronzo
      Presente da: 03-26-2008 Contributi: 255
      no ma penso ci sia qualche problema con il postgre, perchè quando apro l'elefante mi dice "the first step is to create a new database..blabla..." io provo a crearne uno nuovo e mi viene

      Connection to database server lost!

      Further informations:

      Failed to establish connection to '127.0.0.1'.

      vabeh....entro nell'elefante vado su db management e ho solo due opzioni disponibili: crea nuovo db e start database backup, tutto il resto è oscurato.

      Ma il postgre di per se funziona perchè ho scaricato intanto PT3 e ha funzionato subitissimo senza dire "a"...creato il database in un ACT e partito come se nulla fosse...

      Però boh sembra aver litigato con l'elefante...mi rompe assai perchè mi stava simpatico! che posso fare lo reinstallo?
    • Galandil
      Galandil
      Bronzo
      Presente da: 02-19-2008 Contributi: 4.997
      Non è che hai installato PT3 con la versione comprensiva di postgres? Non vorrei che ti sia ritrovato con due installazioni di postgres e due superuser differenti...
    • micaunaltropaolo
      micaunaltropaolo
      Bronzo
      Presente da: 03-26-2008 Contributi: 255
      no no.. prima che installassi PT nn andava più l'elephant...
      infatti PT l'ho messo su per sopperire...

      Per il db di PT ho usato lo stesso superuser e la stessa pwd...

      Si può recuperare il db precedente?
    • micaunaltropaolo
      micaunaltropaolo
      Bronzo
      Presente da: 03-26-2008 Contributi: 255
      Uppo il thread perchè mi interessa recuperare elephant, PT3 è tanto sborone ma mi piaceva di più vedere le sessioni mano a mano come andavano il grafico di overall e poter vedere le mani direttamente ....

      E, dato che non voglio far danni, prima di procedere con tramacci vari volevo sapere cosa posso fare...

      Se reinstallo il postgre e l'elephant perdo il DB? potrebbe servire a qualcosa?

      Se no, come lo ripesco il db con cui l'elephant ha litigato? grazieee
    • Galandil
      Galandil
      Bronzo
      Presente da: 02-19-2008 Contributi: 4.997
      Allora, per sapere se il DB è ancora esistente, nel menu Start, sotto la voce Postgres, trovi il programma PgAdmin III. Lancialo.

      Una volta aperto, nella colonna di sinistra vedrai la voce "PostgreSQL Database Server 8.xx", tasto dx e seleziona Connect. A quel punto clicca sul + che compare a sx della voce, si aprono delle sottovoci, delle quali la prima è Database. Premi di nuovo sul + di Database, e ti comparirà l'elenco di TUTTI i db esistenti in Postgres, controlla che ci sia quello di Elephant.

      Se il DB esiste, vuol dire che Elephant ha problemi a connettersi al database, se non esiste, è sparito per qualche oscuro motivo.

      Nel secondo caso, non puoi fare altro che crearne uno nuovo su Elephant e re-importare tutte le mani.

      Nel primo caso, dovresti ricontrollare superuser/pw di connessione a postgres su Elephant, controlla se è connesso andando su Settings -> Database Management e vedi se l'elenco dei db corrisponde a quello che vedi in PgAdmin III (dovresti vedere ANCHE i db di PT3, insomma, tutti quanti).

      Fammi sapere.
    • micaunaltropaolo
      micaunaltropaolo
      Bronzo
      Presente da: 03-26-2008 Contributi: 255
      Ciao galandil innanzitutto grazie per la pazienza...

      Ho seguito le tue istruzioni ma mi son dovuto fermare quasi subito... infatti dopo aver fatto tasto dx e connetti sulla voce "PostgreSQL Database Server 8.3" e inserito la pwd mi si apre già qui una finestra d'errore :

      Server doesn't listen

      The server doesn't accept connections: the connection library reports
      could not connect to server: Connection refused (0x0000274D/10061) Is the server running on host "127.0.0.1" and accepting TCP/IP connections on port 5432?

      If you encounter this message, please check if the server you're trying to contact is actually running PostgreSQL on the given port. Test if you have network connectivity from your client to the server host using ping or equivalent tools. Is your network / VPN / SSH tunnel / firewall configured correctly?

      For security reasons, PostgreSQL does not listen on all available IP addresses on the server machine initially. In order to access the server over the network, you need to enable listening on the address first.
      For PostgreSQL servers starting with version 8.0, this is controlled using the "listen_addresses" parameter in the postgresql.conf file. Here, you can enter a list of IP addresses the server should listen on, or simply use '*' to listen on all available IP addresses. For earlier servers (Version 7.3 or 7.4), you'll need to set the "tcpip_socket" parameter to 'true'.
      You can use the postgresql.conf editor that is built into pgAdmin III to edit the postgresql.conf configuration file. After changing this file, you need to restart the server process to make the setting effective.
      If you double-checked your configuration but still get this error message, it's still unlikely that you encounter a fatal PostgreSQL misbehaviour. You probably have some low level network connectivity problems (e.g. firewall configuration). Please check this thoroughly before reporting a bug to the PostgreSQL community.


      Cheppalle.

      Se è troppo complicato resetto tutto...solo che mi rompe enormemente perchè voglio il mio graficooooooo :evil:


      Secondo te nella cartella delle mani già elaborate dall'elephant, da lì posso ricreare un nuovo db con quelle stesse mani?
    • Galandil
      Galandil
      Bronzo
      Presente da: 02-19-2008 Contributi: 4.997
      Da quello che hai scritto sembra che il servizio server di postgres non sia attivo, hai provato a lanciare il comando dal menu start -> postgres -> start service?

      Tra l'altro, che PT hai installato, il 2 ol il 3?
    • micaunaltropaolo
      micaunaltropaolo
      Bronzo
      Presente da: 03-26-2008 Contributi: 255
      sì startato... ho installato PT3 dopo che elephant smettesse di funzionare...

      Ma poi PgAdminIII mi da la stessa risposta sia che metto la pwd giusta sia che ne metta una a caso...
      quindi il problema deve stare un po' più in alto...ma nn avrei proprio idea di dove...